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ÜBUNG GRUNDLAGEN GIS

Klassifikation von Rasterdaten
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1. Legen Sie eine neue Kartenansicht namens „LNK“ (UTM Zone 33N) 
und eine zugehörige Geodatenbank „LNK“ in Ihrem Projekt an.

2. Laden Sie Ihren extrahierten Ausschnitt aus dem Satellitenbild 
aus der letzten Übungsaufgabe in die neue Kartenansicht.

3. (Exportieren sie den Ausschnitt in ihre neue Datenbank.)

Datengrundlage und Vorarbeiten
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Maschinelles Lernen: Vorhersage einer Output-Variable ෡Y ∈ 𝔾 basierend auf Input-Variablen X ∈ ℝ𝑝 (mit 𝑝
Einzelvariablen) mit
෡Y ≈ Y

➢ Regression: 𝔾 ⊆ ℝ (kontinuierlich): ෡Y = f(X)

➢ Klassifikation: 𝔾 = ℂ = {𝑐1, 𝑐2, … 𝑐𝑛𝑐} (kategoriell): ∀𝑥 ∈ X → 𝑦(𝑥) = 𝑐 ∈ ℂ

Unsupervised vs superised Klassifikation:

➢ Unsupervised: {X, ෡Y: ෡Y = 𝑂 𝑋 } mittels eines gegebenen Operators 𝑂

➢ Supervised: {X, ෡Y: ෡Y = 𝑂 𝑋 |(𝑥𝑖 , 𝑦𝑖)} mittels eines gegebenen Operators 𝑂 und Trainingsdaten (𝑥𝑖 , 𝑦𝑖)

Theorie: Klassifikation
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Supervised Klassifikation basierend auf multivariater Statistik: 𝑥𝑖 ∈ ℝn×p

➢ Kovarianzmatrix 𝐶𝑐 𝑥𝑖 ∈ ℝ𝑝×𝑝 und Mittelvektor 𝑚𝑐(𝑥𝑖) ∈ ℝ1×𝑝 für jede Klasse 𝑐 ∈ ℂ bestimmen 
für (𝑥𝑖 , 𝑦𝑖 = 𝑐)

➢ Likelihood 𝐿𝑐 𝑥 = PDF x, Cc, mc

⇒ 𝑦 𝑥 = {𝑐 | max
∀𝑐

𝐿𝑐(𝑥) = 𝑐}

Theorie: Maximum-Likelihood-Klassifikation
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Theorie: Maximum-Likelihood-Klassifikation – 1D Beispiel

𝒙

𝑳(𝒙)

𝒄𝟏
𝒄𝟐

𝒄𝟑

𝒙𝟏 𝒙𝟐 𝒙𝟑

𝒙𝟏 → 𝒚𝟏 = 𝒄𝟏
𝒙𝟐 → 𝒚𝟐 = 𝒄𝟐
𝒙𝟑 → 𝒚𝟑 = 𝒄𝟑



6 Dr. Peter Menzel

Grundlagen GIS

Vorteile (Solange die Klassenstatistiken stabil berechenbar sind):

• robust gegenüber ungünstiger Verteilung der Trainingsdaten;

• Minimum an Trainingsdaten ausreichend;

• Robust gegenüber Ausreißern in den Trainingsdaten.

Nachteile:

• Annahme: Daten für jede Klasse sind normalverteilt

• Klassifikation schwierig bei stark „überlappenden“ Klassenstatistiken, vor allen bei sehr ähnlichen 
Mittelvektoren.

Theorie: Maximum-Likelihood-Klassifikation
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Das Ziel ist eine Polygon-Feature-Class, die Polygone beschreiben dabei lokale Regionen gleicher Klasse.

Folgende Schritte 

1. Definition der Trainingssdaten

2. Berechnung der multivariaten Klassenstatistiken

3. Erstellung des klassifizierten Rasters

4. Vektorisierung des klassifizierten Rasters und Erstellung der Feature-Class

Praxis: Landnutzungsklassifikation über ML-Klassifikation in ArcGIS Pro
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• Ziel: Klassifikation des extrahierten Rasters in Regionen unterschiedlicher Landnutzung:

1. Waldflächen

2. Wasserflächen

3. Äcker und Brachland

4. Wiesen und Felder

➢ Selektieren Sie das extrahierte Satellitenbild im Inhaltsbereich

➢ Kernregisterkarte „Bilddaten“, Punkt „Klassifizierungswerkzeuge“ im Bereich „Bildklassifizierung“, 
Werkzeug „Trainingsgebiet-Manager“ 

Praxis: Erstellung der Trainingsdaten für die Klassifikation
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➢ Kernregisterkarte „Bilddaten“, Punkt „Klassifizierungswerkzeuge“ im 
Bereich „Bildklassifizierung“, Werkzeug „Trainingsgebiet-Manager“

1. Erstellen Sie ein neues Schema 

2. Rechts-Klick auf „Neues Schema“ -> Eigenschaften bearbeiten

Praxis: Erstellung der Trainingsdaten für die Klassifikation

1.

2.
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➢ Kernregisterkarte „Bilddaten“, Punkt „Klassifizierungswerkzeuge“ im 
Bereich „Bildklassifizierung“, Werkzeug „Trainingsgebiet-Manager“

1. Erstellen Sie ein neues Schema 

2. Rechts-Klick auf „Neues Schema“ -> Eigenschaften bearbeiten

➢ Benennen Sie das neue Schema, Schließen Sie mit „Speichern“ ab

Praxis: Erstellung der Trainingsdaten für die Klassifikation

1.
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➢ Kernregisterkarte „Bilddaten“, Punkt „Klassifizierungswerkzeuge“ im 
Bereich „Bildklassifizierung“, Werkzeug „Trainingsgebiet-Manager“

1. Erstellen Sie ein neues Schema 

2. Rechts-Klick auf „Neues Schema“ -> Eigenschaften bearbeiten

➢ Benennen Sie das neue Schema, Schließen Sie mit „Speichern“ ab

3. Fügen Sie die neue Klasse „Wald“ hinzu:

➢ Rechts-Klick auf Schema-Name:

oder

➢ Über grünes „Plus“-Icon

Praxis: Erstellung der Trainingsdaten für die Klassifikation
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➢ Kernregisterkarte „Bilddaten“, Punkt „Klassifizierungswerkzeuge“ im 
Bereich „Bildklassifizierung“, Werkzeug „Trainingsgebiet-Manager“

1. Erstellen Sie ein neues Schema 

2. Rechts-Klick auf „Neues Schema“ -> Eigenschaften bearbeiten

➢ Benennen Sie das neue Schema, Schließen Sie mit „Speichern“ ab

3. Fügen Sie die neue Klasse „Wald“ hinzu:

➢ Vergeben Sie einen Namen, einen numerischen Wert (z.B. 1), eine Farbe und, 
ggf. einen Alias und eine Beschreibung

➢ Schließen Sie mit „OK“ ab

Praxis: Erstellung der Trainingsdaten für die Klassifikation
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➢ Kernregisterkarte „Bilddaten“, Punkt „Klassifizierungswerkzeuge“ im 
Bereich „Bildklassifizierung“, Werkzeug „Trainingsgebiet-Manager“

1. Erstellen Sie ein neues Schema 

2. Rechts-Klick auf „Neues Schema“ -> Eigenschaften bearbeiten

➢ Benennen Sie das neue Schema, Schließen Sie mit „Speichern“ ab

3. Fügen Sie die neue Klasse „Wald“ hinzu

4. Zeichnen Sie mittels „Polygon“ großzügig Polygone 
um Regionen, die Sie als Wald erkennen. 
(Doppelklick um Polygon zu beenden)

Praxis: Erstellung der Trainingsdaten für die Klassifikation

4.
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➢ Kernregisterkarte „Bilddaten“, Punkt „Klassifizierungswerkzeuge“ im 
Bereich „Bildklassifizierung“, Werkzeug „Trainingsgebiet-Manager“

1. Erstellen Sie ein neues Schema 

2. Rechts-Klick auf „Neues Schema“ -> Eigenschaften bearbeiten

➢ Benennen Sie das neue Schema, Schließen Sie mit „Speichern“ ab

3. Fügen Sie die neue Klasse „Wald“ hinzu

4. Zeichnen Sie mittels „Polygon“ großzügig Polygone 
um Regionen, die Sie als Wald erkennen. 
(Doppelklick um Polygon zu beenden)

Praxis: Erstellung der Trainingsdaten für die Klassifikation

4.
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➢ Kernregisterkarte „Bilddaten“, Punkt „Klassifizierungswerkzeuge“ im 
Bereich „Bildklassifizierung“, Werkzeug „Trainingsgebiet-Manager“

1. Erstellen Sie ein neues Schema 

2. Rechts-Klick auf „Neues Schema“ -> Eigenschaften bearbeiten

➢ Benennen Sie das neue Schema, Schließen Sie mit „Speichern“ ab

3. Fügen Sie die neue Klasse „Wald“ hinzu

4. Zeichnen Sie mittels „Polygon“ großzügig Polygone 
um Regionen, die Sie als Wald erkennen. 
(Doppelklick um Polygon zu beenden)

5. Führen Sie ihre Einzelpolygone zu einer Stichprobe zusammen.
Dafür müssen Sie alle betreffenden Polygone selektiert haben.

Praxis: Erstellung der Trainingsdaten für die Klassifikation

5.
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• Wiederholen Sie dies für die weiteren Klassen

1. Wasserflächen

2. Acker / Brachland

3. Feld / Wiese

Praxis: Erstellung der Trainingsdaten für die Klassifikation

1 2

3
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• Wiederholen Sie dies für die weiteren Klassen

1. Wasserflächen

2. Acker / Brachland

3. Feld / Wiese

Praxis: Erstellung der Trainingsdaten für die Klassifikation

1 2

3
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• Wiederholen Sie dies für die weiteren Klassen

1. Wasserflächen

2. Acker / Brachland

3. Feld / Wiese

• Speichern Sie Ihre Trainingsgebiete als Feature-Class in ihre
Datenbank

Praxis: Erstellung der Trainingsdaten für die Klassifikation

1 2

3
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• Wiederholen Sie dies für die weiteren Klassen

1. Wasserflächen

2. Acker / Brachland

3. Feld / Wiese

• Speichern Sie Ihre Trainingsgebiete als Feature-Class in ihre
Datenbank

Praxis: Erstellung der Trainingsdaten für die Klassifikation

1 2

3

Symbolisierung 
manuell angepasst
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• Spatial Analyst Tools > Multivariate > 
Signaturen erstellen

Praxis: Berechnung der multivariaten Klassenstatistiken und 
Erstellung der Signaturdatei
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Praxis: Klassifikation des Rasterlayers

• Spatial Analyst Tools > Multivariate > 
Maximum-Likelihood-Klassifizierung

➢ Geben Sie als Eingaberaster ihr extrahiertes Satelliten-
bild und ihre Signaturdatei an

➢ Geben Sie ein Ausgaberaster für die Klassifikation an

➢ Sie können zusätzlich ein Ausgabe-Konfidenzraster
angeben
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Praxis: Klassifikation des Rasterlayers

• Spatial Analyst Tools > Multivariate > 
Maximum-Likelihood-Klassifizierung

➢ Geben Sie als Eingaberaster ihr extrahiertes Satelliten-
bild und ihre Signaturdatei an

➢ Geben Sie ein Ausgaberaster für die Klassifikation an

➢ Sie können zusätzlich ein Ausgabe-Konfidenzraster
angeben
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Praxis: Konfidenz der Klassifikation

• Spatial Analyst Tools > Multivariate > 
Maximum-Likelihood-Klassifizierung

➢ Geben Sie als Eingaberaster ihr extrahiertes Satelliten-
bild und ihre Signaturdatei an

➢ Geben Sie ein Ausgaberaster für die Klassifikation an

➢ Sie können zusätzlich ein Ausgabe-Konfidenzraster
angeben

➢ Sicher

➢ Sehr unsicher
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Praxis: Klassifikation des Rasterlayers

• Spatial Analyst Tools > Multivariate > 
Maximum-Likelihood-Klassifizierung

Oder alternativ

• Rasterfunktionen -> Klassifizierung ->
ML-Klassifizierung

• Temporäres Layer

• Keine Konfidenz
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• Conversion Tools -> Von Raster -> Raster in Polygon

Praxis: Vektorisierung des klassifizierten Rasters
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• Conversion Tools -> Von Raster -> Raster in Polygon

Praxis: Vektorisierung des klassifizierten Rasters
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Das aktuelle Klassifikationsergebnis hat ein Problem:

Im Bereich von Siedlungen ist die Klassifikation sehr 
unsicher, da dafür noch keine eigene Klasse existiert.

1. Erweitern Sie Ihr Klassifikationsschema um eine
weitere Klasse für Siedlungen und digitalisieren Sie
zugehörige Trainingsgebiete.

2. Erstellen sie eine neue Signaturdatei und 
wiederholen sie die Klassifikation.

Übungsaufgabe: Erweiterung der Landnutzungsklassifikation
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3. Führen Sie mittels Spatial Analyst Tools->Multivariate->Hauptkomponentenanalyse
eine Hauptkomponentenanalyse Ihres extrahierten Satellitenbildes durch. Dadurch werden die 
existierenden Farbkanäle in linear unabhängige Kanäle überführt. Dies sollte die Klassifikation 
verbessern. Verwenden Sie 3 Hauptkomponenten.

4. Erstellen sie eine neue Signaturdatei für Ihre Trainingsgebiete und das Ergebnisraster der 
Hauptkomponentenanalyse, wiederholen sie die Klassifikation ein drittes Mal.

5. Erstellen Sie eine Polygon-Feature-Class aus dem aus Ihrer Sicht optimalen Klassifikationsergebnis.

Übungsaufgabe: Erweiterung der Landnutzungsklassifikation
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Bestimmt die orthogonalen Achsen maximaler Variabilität in einem mehrdimensionalen Datensatz.

Theorie: Hauptkomponentenanalyse / Principle Component Analysis (PCA)

P
a
ra

m
e
te

r 
B

Daten

Parameter A
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Bestimmt die orthogonalen Achsen maximaler Variabilität in einem mehrdimensionalen Datensatz.

Theorie: Hauptkomponentenanalyse / Principle Component Analysis (PCA)
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Parameter A
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1. Datensatz: X =

𝑥1,1 ⋯ 𝑥1,𝑝
⋮ ⋱ ⋮

𝑥𝑛,1 ⋯ 𝑥𝑛,𝑝
, mit 𝑛 Datenpunkte und 𝑝 Datenparametern

2. Berechnung der Kovarianz-Matrix 

𝐶𝑉𝑋 =෍

𝑖

𝑛

𝑥𝑖,1…𝑥𝑖,𝑝 − 𝜇1…𝜇𝑝
𝑇
∙ 𝑥𝑖,1…𝑥𝑖,𝑝 − 𝜇1…𝜇𝑝

3. Berechnung der Eigenwerte 𝐸𝑋 und Eigenvektoren 𝑉𝑋 von 𝐶𝑉𝑋
1. Eigenvektoren: Hauptkomponenten

2. Eigenwerte: Varianz entlang der zugehörigen Hauptkomponente  

4. Sortierung von 𝑉𝑋 anhand absteigender Varianz 𝑉𝑋 = 𝑉1⋯𝑉𝑝
mit 𝐸1 > 𝐸2 > ⋯ > 𝐸𝑝

Theorie: Hauptkomponentenanalyse / Principle Component Analysis (PCA)
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5. Projektion 𝑋′ in den Raum der Hauptkomponenten : 𝑉𝑋𝑋
′ = 𝑋 → 𝑋′ = 𝑉𝑋

−1𝑋

6. Datenreduktion von 𝑝 zu 𝑝 ′ Parametern mit 𝑝′ < 𝑝: 
Verwendung von 𝑉𝑋

𝑝′ = 𝑉1⋯𝑉𝑝′

Theorie: Hauptkomponentenanalyse / Principle Component Analysis (PCA)

32

𝑋 𝑋′

X =

𝑥1,𝑅𝑜𝑡 𝑥1,𝐺𝑟ü𝑛 𝑥1,𝐵𝑙𝑎𝑢
⋮ ⋮ ⋮

𝑥𝑛,𝑅𝑜𝑡 𝑥𝑛,𝐺𝑟ü𝑛 𝑥𝑛,𝐵𝑙𝑎𝑢


