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Volumenobjekte in Skua-Gocad

Erstellung von Volumenobjekten in Skua-Gocad. (Kapitel 10/11 im Tutorial)

1. Voxet

2. Model3D

3. Solid

4. SGrid
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Volumenobjekte in Skua-Gocad

Vorarbeiten

Laden Sie die Datei 
sgrid.zip aus OPAL. 
Entpacken Sie sie in 
ein lokales 
Verzeichnis und 
starten Sie das 
beinhaltete Projekt.
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Volumenobjekte in Skua-Gocad

Vorarbeiten

Erstellen Sie jetzt ein neues Projekt, im welchem Sie das
Add-On Finite Element Mesh Constructor laden.

Importieren Sie alle Objekte 
aus dem vorherigen Projekt.



5

Volumenobjekte in Skua-Gocad

Voxet

• Regelmäßiges Parallelepiped-Gitter

• Ursprung 𝑋0 = (𝑥0, 𝑦0, 𝑧0)
• Kathesisches Gitterkoordinaten-System mit u-, v- und w-Achse
• Zellenanzahl pro Gitterachse: 𝑛𝑢, 𝑛𝑣, 𝑛𝑤
• Schrittvektoren: 𝑢𝑠𝑡𝑒𝑝 = 𝑥𝑢, 𝑦𝑢, 𝑧𝑢 , 𝑣𝑠𝑡𝑒𝑝 = 𝑥𝑣, 𝑦𝑣, 𝑧𝑣 , 𝑤𝑠𝑡𝑒𝑝 = 𝑥𝑤, 𝑦𝑤, 𝑧𝑤
• Relevante Punkte sind immer die Zellmittelpunkte

• Ԧ𝑥𝑖,𝑗,𝑘 = 𝑋0 + 𝑖 ∗ 𝑢𝑠𝑡𝑒𝑝 + 𝑗 ∗ Ԧ𝑣𝑠𝑡𝑒𝑝 + 𝑘 ∗ 𝑤𝑠𝑡𝑒𝑝
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Volumenobjekte in Skua-Gocad

Voxet

• Regelmäßiges Parallelepiped-Gitter

• Ursprung 𝑋0 = (𝑋0, 𝑌0, 𝑍0)
• Kathesisches Gitterkoordinaten-System mit u-, v- und w-Achse
• Zellenanzahl pro Gitterachse: 𝑛𝑢, 𝑛𝑣, 𝑛𝑤
• Schrittvektoren: 𝑢𝑠𝑡𝑒𝑝 = 𝑥𝑢, 𝑦𝑢, 𝑧𝑢 , 𝑣𝑠𝑡𝑒𝑝 = 𝑥𝑣, 𝑦𝑣, 𝑧𝑣 , 𝑤𝑠𝑡𝑒𝑝 = 𝑥𝑤, 𝑦𝑤, 𝑧𝑤
• Relevante Punkte sind immer die Zellmittelpunkte

• Ԧ𝑥𝑖,𝑗,𝑘 = 𝑋0 + 𝑖 ∗ 𝑢𝑠𝑡𝑒𝑝 + 𝑗 ∗ Ԧ𝑣𝑠𝑡𝑒𝑝 + 𝑘 ∗ 𝑤𝑠𝑡𝑒𝑝
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Volumenobjekte in Skua-Gocad

Voxet erstellen

Ziel ist in einem ersten Schritt die Erstellung eines Voxet-Objektes, welches die 
stratigrafische Einheit mittels einer ID pro Zelle beinhaltet.

Das zu erstellende Voxet muss dabei kleiner sein, als die zugrunde-
liegenden Flächen.
Voxet mode
• New > From Object Box
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Volumenobjekte in Skua-Gocad

Voxet in Regionen unterteilen

Mittels der vorhandenen Flächenobjekte soll das erstelle Voxet jetzt in
Regionen unterteilt werden.

1. Model > New > Add Surfaces

2. Model > New > Build
Uncheck!
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Volumenobjekte in Skua-Gocad

Voxet in Regionen unterteilen

Mittels der vorhandenen Flächenobjekte soll das erstelle Voxet jetzt in
Regionen unterteilt werden.

1. Model > New > Add Surfaces

2. Model > New > Build
Uncheck!
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Volumenobjekte in Skua-Gocad

Voxet in Regionen in Eigenschaft überführen

Die Regionen lassen sich als Property in den Zellen speichern:

1. Property > create

2. Property > Set Constant 
Wiederholung für alle Regionen!
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Volumenobjekte in Skua-Gocad

Voxet in Regionen in Eigenschaft überführen

Die Regionen lassen sich als Property in den Zellen speichern:

1. Property > create

2. Property > Set Constant 
Wiederholung für alle Regionen!
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Volumenobjekte in Skua-Gocad

Model3D

• Volumenrepräsentation durch konsistente Boundary Representation mittel
triangulierte Flächen
• Jede Region wird durch einen triangulierten Polyeder der Hülle repräsentiert

Erster Schritt: Erstellung einer äußeren Begrenzungsfläche -> Surface mode

1. New > From Grid >From Voxet Cage

2. Tools > Parts > Merge All

3. Tools > Split > Split All (3x)
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Volumenobjekte in Skua-Gocad

Model3D

• Volumenrepräsentation durch konsistente Boundary Representation mittel
triangulierte Flächen
• Jede Region wird durch einen triangulierten Polyeder der Hülle repräsentiert

Erster Schritt: Erstellung einer äußeren Begrenzungsfläche -> Surface mode

1. New > From Grid >From Voxet Cage

2. Tools > Parts > Merge All

3. Tools > Split > Split All (3x)
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Volumenobjekte in Skua-Gocad

Model3D

Surface mode

1. Model3d > 
From Surfaces

2. Model3d > more >
remove free extremities
(für alle Regionen)
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Volumenobjekte in Skua-Gocad

Model3D

Mehrere Blöcke zu einem Layer
kombinieren:

1. Model3d > Layers >
Create one frome region

2. Object panel > Structural Models >
Rechts-Klick Region_6 > Add to Layer
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Volumenobjekte in Skua-Gocad

Model3D

Mehrere Blöche zu einem Layer
kombinieren:

1. Model3d > Layers >
Create one frome region

2. Object panel > Structural Models >
Rechts-Klick Region_6 > Add to Layer
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Volumenobjekte in Skua-Gocad

Model3D

Regionen als triangulierte Flächen extrahieren

1. New > From Others > Model Region
Erstellen Sie eine Fläche pro Region
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Volumenobjekte in Skua-Gocad

Model3D

Regionen als triangulierte Flächen extrahieren

1. New > From Others > Model Region
Erstellen Sie eine Fläche pro Region
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Volumenobjekte in Skua-Gocad

Solid 

Tetraeder-Gitter

Finite Element Mesh Workflow …

Doppel-Klick, erstellen Sie ein Tetraedergitter basierend
auf dem erstellten Model3D. Verwenden Sie für
die Tetraedergröße: 20 m
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Volumenobjekte in Skua-Gocad

Solid 

Tetraeder-Gitter

Finite Element Mesh Workflow …

Doppel-Klick, erstellen Sie ein Tetraedergitter basierend
auf dem erstellten Model3D. Verwenden Sie für
die Tetraedergröße: 20 m
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Reguläres 3D Gitter, welches deformiert und auch geschnitten werden kann.



22

Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Ziel dieser Übung ist die Modellierung eines gold-führenden Quarzganges.

1. Erstellung eines Flächenmodells basierend auf Kurvenobjekten.

2. Modellierung eines SGrids für innerhalb des Flächenmodells

3. Interpolation des Goldgehaltes mittels DSI.

4. Identifikation der profitablen Regionen (Au > 0.3 ppm).
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Bitte erstellen Sie ein neues Skua-Gocad Projekt.

Import der relevanten Daten

1. Importieren Sie die beiden Curve-Objekte bottomwall und hangingwall
aus dem Projekt der vorherigen Übung.

2. Importieren Sie die Daten zum Goldgehalt aus der Datei au_grades.txt
File > Import > Horizon Interpretation > Column-based File
• Benennen Sie das neue Objekt nach dem Dateinamen
• Erstellen Sie für die 5. Spalte eine neue Eigenschaft Au
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Erstellung des Flächenmodells

1. Erstellen Sie die Bounding Box aller Objekte als Voxet. 

2. Modellieren Sie über DSI aus den Kurven-Objekten zwei Flächenobjekte 
innerhalb der Grenzen der Bounding Box.
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Erstellung des Flächenmodells

1. Erstellen Sie die Bounding Box aller Objekte als Voxet. 

2. Modellieren Sie über DSI aus den Kurven-Objekten zwei Flächenobjekte 
innerhalb der Grenzen der Bounding Box.
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Erstellung des SGrid-Objektes
SGrid-mode

1. New > From Object Box
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Erstellung des Sgrid-Objektes
SGrid-mode

1. New > From Object Box
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Erstellung des SGrid-Objektes

2. Tools > Conformable >
Between Top and Bottom

3. Erstellen Sie eine Kopie des 
erstellten Gitters mit dem 
Namen southgrid
Diese Kopie wird später benötigt!
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Erstellung des SGrid-Objektes

2. Tools > Conformable >
Between Top and Bottom
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Eigenschaftsinterpolation mittels DSI

1. Constraints > Set Property Control 
Points > Between Top and Bottom



33

Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Eigenschaftsinterpolation mittels DSI

1. Constraints > Set Property Control 
Points > Between Top and Bottom

2. Interpolation > Initialize Property
(Multi-Grid)
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Eigenschaftsinterpolation mittels DSI

1. Constraints > Set Property Control 
Points > Between Top and Bottom

2. Interpolation > Initialize Property
(Multi-Grid)
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Eigenschaftsinterpolation mittels DSI

1. Constraints > Set Property Control 
Points > Between Top and Bottom

2. Interpolation > Initialize Property
(Multi-Grid)
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Erstellen von so genannten Iso-Flächen
Das heißt Flächen, welche den Verlauf einen konstanten Eigenschaftswertes in 
einem Gitter abbilden.

Surface mode

New > From Grid > Grid Iso-Property
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Erstellen von so genannten Iso-Flächen
Das heißt Flächen, welche den Verlauf einen konstanten Eigenschaftswertes in 
einem Gitter abbilden.

Surface mode

New > From Grid > Grid Iso-Property



38

Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Unterteilung des SGrids in profitable und nicht-profitable Regionen

SGrid mode

1. Erstellung der Region mineable, deren Abbau 
profitable wäre.
Region > Create
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Unterteilung des SGrids in profitable und nicht-profitable Regionen

SGrid mode

1. Erstellung der Region mineable, deren Abbau 
profitable wäre.
Region > Create

Region > Initialize > From Property Range
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Unterteilung des SGrids in profitable und nicht-profitable Regionen

SGrid mode

1. Erstellung der Region minable, deren Abbau 
profitable wäre.
Region > Create

Region > Initialize > From Property Range
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Unterteilung des SGrids in profitable und nicht-profitable Regionen

2. Erstellung der Region non-mineable als Komplement der Region mineable.

Region > Copy

Region > Edit > Complement
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Unterteilung des SGrids in profitable und nicht-profitable Regionen

2. Erstellung der Region non-mineable als Komplement der Region mineable.

Region > Copy

Region > Edit > Complement
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Volumenobjekte in Skua-Gocad

Structured Grid (SGrid) 

Meta-Informationen und Statistiken

1. Zellenanzahl allgemein
Style Editor > Info 

2. Zellenanzahl in einer Region
Rechts-Klick auf eine Region im Object Panel:
Compute > Node/Cell Count in Region

3. Volumen einer Region
Rechts-Klick auf eine Region im Object Panel:
Compute > Region Volume
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Volumenobjekte in Skua-Gocad

Interpolation des Goldgehaltes …

… unter Berücksichtigung der Störung

Es gibt 2 unterschiedliche Bereiche mit nicht-profitabler Vererzung:
• Großer Bereich in Norden
• Kleines „dead hole“ im südlichen Bereich

Es ist bekannt, dass der Untersuchungsbereich von einer Störung unterteilt 
wird. Diese wurde bisher bei der Interpolation des Goldgehaltes nicht 
berücksichtigt.
Ziel ist jetzt den gesamten Bereich nördlich der Störung von der Interpolation 
auszuschließen.
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Volumenobjekte in Skua-Gocad

Interpolation des Goldgehaltes …

… unter Berücksichtigung der Störung

1. Importieren Sie das Kurven-Objekt fault auf dem Projekt der vorherigen 
Übung.

2. Erstellen Sie die Fläche der Störung: Surface mode
New > From Curves > Several Curves (number of levels: 10)
Selektieren Sie interaktive die beiden Kurven
(Achtung Strg-Taste gedrückt halten!)
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Volumenobjekte in Skua-Gocad

Interpolation des Goldgehaltes …

… unter Berücksichtigung der Störung

1. Importieren Sie das Kurven-Objekt fault auf dem Projekt der vorherigen 
Übung.

2. Erstellen Sie die Fläche der Störung: Surface mode
New > From Curves > Several Curves (number of levels: 10)
Selektieren Sie interaktive die beiden Kurven
(Achtung Strg-Taste gedrückt halten!)
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Volumenobjekte in Skua-Gocad

Interpolation des Goldgehaltes …

… unter Berücksichtigung der Störung

3. Erstellen einer Region south im Objekt southgrid für 
den Bereich südlich der Störung: SGrid mode
Region > Create

Region > Inititalize > From Surface
Region > Edit > Complement
Region > Edit > Filter > Manually
Selektieren Sie den Bereich südlich der Störung
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Volumenobjekte in Skua-Gocad

Interpolation des Goldgehaltes …

… unter Berücksichtigung der Störung

3. Erstellen einer Region south im Objekt southgrid für 
den Bereich südlich der Störung: SGrid mode
Region > Create

Region > Inititalize > From Surface
Region > Edit > Complement
Region > Edit > Filter > Manually
Selektieren Sie den Bereich südlich der Störung
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Volumenobjekte in Skua-Gocad

Interpolation des Goldgehaltes …

… unter Berücksichtigung der Störung

4. Erstellen Sie eine komplementäre Region north für den nördlichen Bereich 
(inkl. des Bereiches um die Störung)

north

south
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Volumenobjekte in Skua-Gocad

Interpolation des Goldgehaltes …

… unter Berücksichtigung der Störung

4. Kopieren Sie das PointSet au_grades in ein neues Objekt south_grades.
Beachten Sie, dass alle Eigenschaft mit kopiert werden.
Löschen Sie alle Punkt nördlich der Störung.
PointSet mode
Tools > Segregate with Surfaces

Tools > Part > Delete Selection



51

Volumenobjekte in Skua-Gocad

Interpolation des Goldgehaltes …

… unter Berücksichtigung der Störung

4. Kopieren Sie das PointSet au_grades in ein neues Objekt south_grades.
Beachten Sie, dass alle Eigenschaft mit kopiert werden.
Löschen Sie alle Punkt nördlich der Störung.
PointSet mode
Tools > Segregate with Surfaces

Tools > Part > Delete Selection
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Volumenobjekte in Skua-Gocad

Interpolation des Goldgehaltes …

… unter Berücksichtigung der Störung

5. Interpolation des Goldgehaltes mittels DSI.
SGrid mode:
Constraints > Set Property Control Points
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Volumenobjekte in Skua-Gocad

Interpolation des Goldgehaltes …

… unter Berücksichtigung der Störung

5. Interpolation des Goldgehaltes mittels DSI.
SGrid mode:
Constraints > Set Property Control Points

Interpolation > Initialize Property 
(Multi-Grid)
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Volumenobjekte in Skua-Gocad

Interpolation des Goldgehaltes …

… unter Berücksichtigung der Störung

5. Interpolation des Goldgehaltes mittels DSI.
SGrid mode:
Constraints > Set Property Control Points

Interpolation > Initialize Property 
(Multi-Grid)
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Volumenobjekte in Skua-Gocad

Abschätzung der profitables Gold Ressource

1. Alle Zellen mit nicht-profitables Goldvererzung auf Null setzen.
Compute > Apply Script > on Object …
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Volumenobjekte in Skua-Gocad

Abschätzung der profitables Gold Ressource

1. Alle Zellen mit nicht-profitables Goldvererzung auf Null setzen.
Compute > Apply Script > on Object …

2. Erstellen Sie eine Property Au_weights.

3. Erstellen Sie eine weitere Property für die Zell-Volumina:
Compute > Property > Compute Cell Volume
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Volumenobjekte in Skua-Gocad

Abschätzung der profitables Gold Ressource

1. Alle Zellen mit nicht-profitables Goldvererzung auf Null setzen.
Compute > Apply Script > on Object …

2. Erstellen Sie eine Property Au_weights.

3. Erstellen Sie eine weitere Property für die Zell-Volumina:
Compute > Property > Compute Cell Volume

4. Berechnen Sie die Masse des verfügbaren 
Goldes:
Compute > Apply Script > on Object …
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Volumenobjekte in Skua-Gocad

Abschätzung der profitables Gold Ressource
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Volumenobjekte in Skua-Gocad

Abschätzung der profitables Gold Ressource

1. Alle Zellen mit nicht-profitables Goldvererzung auf Null setzen.
Compute > Apply Script > on Object …

2. Erstellen Sie eine Property Au_weights.
3. Erstellen Sie eine weitere Property für die Zell-Volumina:

Compute > Property > Compute Cell Volume
4. Berechnen Sie die Masse des verfügbaren 

Goldes:
Compute > Apply Script > on Object …

5. Export der Ergebnisse nach MS Excel
File > Export > Sgrid > Export Properties to Excel
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Volumenobjekte in Skua-Gocad

Abschätzung der profitables Gold Ressource

1. Alle Zellen mit nicht-profitables Goldvererzung auf Null setzen.
Compute > Apply Script > on Object …

2. Erstellen Sie eine Property Au_weights.
3. Erstellen Sie eine weitere Property für die Zell-Volumina:

Compute > Property > Compute Cell Volume
4. Berechnen Sie die Masse des verfügbaren 

Goldes:
Compute > Apply Script > on Object …

5. Export der Ergebnisse nach MS Excel
File > Export > Sgrid > Export Properties to Excel
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Volumenobjekte in Skua-Gocad

Explorative Datenanalyse

Skua-Gocad erlaubt Ihnen, vorhandene Eigenschaften von Objekten zu analysieren
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Volumenobjekte in Skua-Gocad

Explorative Datenanalyse

Stellen Sie das Histogramm zur Eigenschaft AU des PointSets au_grades sowie 
dar des SGrids augrid dar. Vergleichen Sie die beiden Eigenschaftsverteilungen.
Was fällt Ihnen auf?

au_grades augrid
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Volumenobjekte in Skua-Gocad

Räumliche Datenanalyse / Variogram

• Räumliche Datenanalyse umfasst Verfahren, die es erlauben, die 
räumliche Verteilung einer Eigenschaft zu charakterisieren. Sie ist die 
grundlegende Voraussetzung für eine geostatistische Interpolation dieser
Eigenschaft, da über räumliche Datenanalyse die Parameter des 
Vorhersagemodells bestimmt werden können.

• Das Hauptwerkzeugt dafür ist 
das so genannte Variogram.
Es beschreibt  den Grad 
der räumliches Abhängigkeit 
einer Eigenschaft.
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Volumenobjekte in Skua-Gocad

Variogram

• Es verknüpft die Varianz von Eigenschaftsdifferenzen zwischen 
zwei Datenpunkten mit der Distanz zwischen den Punkten.

• Empirisches Variogram: 
• Basiert auf den gegeben Datenpunkten
• Die zur Bestimmung der Parameter des theoretischen Variograms

• Theoretisches Variogram:
• Funktion, welche die räuml.

Abhängigkeit über ein math. 
Modell beschreibt.

• Anwendungs-/Anwender-
abhängig, z.T. subjektiv
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Volumenobjekte in Skua-Gocad

Variogram

• Wichtige Parameter zur Bestimmung des empirischen Variogramms:
• Lag distance: Stützpunktabstand zur Berechnung des Variograms
• Lag: Anzahl der Stützpunkte zur Brechnung des Variograms
• Sampling rate: Anteil der Daten zur Berechnung des Variograms
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Volumenobjekte in Skua-Gocad

Variogram

• Wichtige Parameter zur Bestimmung des theor.  Variograms:
• Nugget Effect: lokale Microvariabilität
• Range: Max. Distanze bis zu der räuml. Ahängigkeit angenommen 

werden kann 
• Sill: Max. Varianz außerhalb des Range 
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Volumenobjekte in Skua-Gocad

Variogram

Unterziehen Sie die Eigenschaft AU des PointSets au_grades einer räumlichen
Datenanalyse (Spatial data analysis) und erstellen Sie ein Variogrammmodell.

Verwenden Sie dafür den Skua-Gocad Variogram Analyzer: 
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Volumenobjekte in Skua-Gocad

Räumliche Datenanalyse / Variogramm

Unterziehen Sie die Eigenschaft AU des PointSets au_grades einer räumlichen
Datenanalyse (Spatial data analysis) und erstellen Sie ein Variogrammmodell.

Verwenden Sie dafür den Skua-Gocad Variogram Analyzer: 
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Volumenobjekte in Skua-Gocad

Räumliche Datenanalyse / Variogramm

Unterziehen Sie die Eigenschaft AU des PointSets au_grades einer räumlichen
Datenanalyse (Spatial data analysis) und erstellen Sie ein Variogrammmodell.

Verwenden Sie dafür den Skua-Gocad Variogram Analyzer: 
1.

2.

3.
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Volumenobjekte in Skua-Gocad

Räumliche Datenanalyse / Variogramm

Unterziehen Sie die Eigenschaft AU des PointSets au_grades einer räumlichen
Datenanalyse (Spatial data analysis) und erstellen Sie ein Variogrammmodell.

Verwenden Sie dafür den Skua-Gocad Variogram Analyzer: 
1.

2.
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Volumenobjekte in Skua-Gocad

Räumliche Datenanalyse / Variogramm

Unterziehen Sie die Eigenschaft AU des PointSets au_grades einer räumlichen
Datenanalyse (Spatial data analysis) und erstellen Sie ein Variogrammmodell.

Verwenden Sie dafür den Skua-Gocad Variogram Analyzer: 
1.

2.
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Volumenobjekte in Skua-Gocad

Geostatistische 

Interpolation / Kriging

Interpolieren Sie im SGrid augrid den 
Goldgehalt über Simple Kriging.

Geostatistics > Estimation > Kriging
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Volumenobjekte in Skua-Gocad
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Volumenobjekte in Skua-Gocad
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Volumenobjekte in Skua-Gocad
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Volumenobjekte in Skua-Gocad

Wenn Sie sich weitergehend mit räumlicher Analyse und Geostatistik befassen
wollen:

• Kapitel 12 im Tutorial, der Datensatz WellPoints.txt befindet sich im OPAL

• Lehrveranstaltung „Multivariate- und Geostatistik“ (Prof. Gerhards)



Institut für Geophysik und Geoinformatik

Dr. Peter Menzel

Gustav-Zeuner-Str. 12

09599 Freiberg

Tel. +49(0)3731 39-3815


